Elastix Brasil

  • Increase font size
  • Default font size
  • Decrease font size

Elastix
Seja bem-vindo, Visitante
Por Favor Entrar ou Registrar.    Esqueceu a senha?
Instalação do Elastix em Servidor Remoto (Cloud) (1 visualizando) (1) Visitante
Ir para baixo Favorito por: 0
TÓPICO: Instalação do Elastix em Servidor Remoto (Cloud)
#8292
flabit (Usuário)
Fresh Boarder
Mensagens: 1
graphgraph
Usuários Offline Clique aqui para ver o perfil deste usuário
Instalação do Elastix em Servidor Remoto (Cloud) 3 Anos, 5 Mês atrás Popularidade: 0  
Olá amigos!

Me baseando em tutoriais, tentei fazer uma instalação do Elastix, mas aparentemente a instalação não conclui.

Acredito que isso se deve a problemas em dependências do yum no momento em que aplico yum install elastix.

Segue os passos que segui:


Atualização geral

# yum -y update

Download do ISO Elastix

# wget kaz.dl.sourceforge.net/project/elastix/E...86-bin-02Apr2012.iso

Montagem da unidade que conterá a imagem ISO

# mkdir /mnt/iso
# mount -o loop Elastix-2.3.0-i386-bin-02Apr2012.iso /mnt/iso
# cd /mnt/iso


Instalação EPEL

# rpm -ivh ftp://mirror.cs.princeton.edu/pub/mirrors/fedora-epel/5/i386/epel-release-5-4.noarch.rpm

Criei o arquivo repo para a imagem ISO

# nano /etc/yum.repos.d/elastix-cd.repo

[elastix-cd]
name=Elastix RPM Repo CD
baseurl=file:///mnt/iso/
gpgcheck=0
enabled=1a


Agora que vem o problema, justamente na instalação do Elastix

# yum -y install elastix

Falhas na hora da instalação do comando anterior

Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libodbc.so.1()(64bit)
Error: Package: elastix-pbx-2.4.0-7.noarch (elastix-updates)
Requires: perl(Asterisk::AGI)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: librpm-4.4.so()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libpq.so.4()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libnetsnmp.so.10()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libcurl.so.3()(64bit)
Error: Package: elastix-portknock-0.0.1-0.x86_64 (elastix-updates)
Requires: libpcap.so.0.9.4()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: librpmio-4.4.so()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)yuyu
Requires: libnetsnmphelpers.so.10()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libsensors.so.3()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libnetsnmpagent.so.10()(64bit)
Error: Package: 2009020507:asterisk-11.10.0-0.x86_64 (elastix-updates)
Requires: libnetsnmpmibs.so.10()(64bit)


Daqui em diante, nem adianta eu continuar com os próximos passos por que o Elastix não consta como instalado, pois logo após esse comando, para testar, apliquei o comando # yum update elastix e apresentou a seguinte mensagem:

Setting up Update Process
Package(s) elastix available, but not installed.
No Packages marked for Update


Os próximos passos seriam:

# Reboot
# /etc/rc3.d/S66elastix-firstboot start
# servide https start
# service asterisk start


Alguém já efetuou instalação do Elastix em um Cloud que de repente possa dar uma dica?

Muito obrigado!


Abraços


Flávio
 
Logado Logado  
  O administrador desabilitou acesso publico para escrita.
Ir para cima